RIP konfigurationer

Routrar som kör RIP hanterar en routing-databas. Databasen innehåller vägar eller routes samt deras associationer och andra kompletterande routing-information. I databasen lagras information som destinationsadress och dess associationer med routrars interface/adress. Varje väg eller route i routing-databasen tilldelas ett mått (Metric) som anger avståndet till destinationen räknat i antal hopp eller routrar som paket passerar. Antal hopp är från 0 till 15. Databasen struktureras så att innehållet kan visas i tabeller, främst i routing-tabellen.

När en router är RIP-aktiverad skickar denna en begäran eller request om en uppdatering till närliggande routrar. När router får svar eller response i form av uppdatering uppdateras routing-databasen. Uppdateringar styrs med olika tidsrutiner via regelbundna uppdateringar. Dessa uppdateringar kallas för periodiska och är tidskontrollerade. Varje 30 sekund skickas ut eller tas emot uppdateringar och när detta inte sker markeras information i databasen som inaktiva eller i viloläge. Det betyder att markerade information inte kan användas under en viss tid. Om dessa markeringar inte uppdateras efter en uppsatt tid tas de bort från databasen därmed från routing-tabellen.

Mest på grund av felaktiga konfigurationer kan uppstå uppdateringar med felaktiga innehåll som överförs från routrar till routrar. Detta kallas routing-loops. RIP undviker routing-loopar med metoder som Count till infinity, Split horizont, triggered uppdates och några andra metoder till.

Bild 1: RIPv1 format

RIPv1 meddelande format

RIP använder UDP och därmed dess meddelande kallas för datagram. Men datatrafiken generaliseras med paket och RIP paket struktureras med header och poster med vägar till destinationsnätverk.

Bild 1 illustrerar de två delar i ett RIP meddelande och deras fält.

  • Header
    • Command – indikerar om paketet är av typ 1 eller 2. 1 betyder request och 2 response
    • Version – indikerar RIP version. Version 1 identifieras med 0x01
    • Must be zero – indikerar reservationer till vidare utveckling eller att fälten används inte
  • Route entries
    • Address Family – identifierar protokollet:
      • 0 önskas hela routing-tabell i uppdateringar
      • 1 odefinierad
      • 2 identifiera protokollet IP
      • 3 – 65 534 odefinierade
      • 65 535 autentisering
    • IP address – identifierar destinationsnätverket
    • Metric – indikerar antal hopp

IANA definierar värdena ovan. Om du kickar på länken kommer du att se RIP parametrarna.

Enligt Cisco kan en RIP uppdatering innehålla upp till 25 vägar eller routes. Maximal storlek för ett datagram är 504 byte utan att inkludera IP eller UDP header.

RIPv2 meddelande format

Stödjer CIDR och VLSM och det ger en annorlunda formatering

Bild 2: RIPv2 format

Cisco-implementeringen av RIP Version 2 (RIPv2) stöder

  • textbaserat meddelande och MD5 autentiserings algoritm
  • route aggregering
  • CIDR
  • VLSM

Laborations topologi och konfigurationer

Här nedan anges alla nödvändiga kommando för att konfigurera routing i ett vist nätverk. Kommandot passive-interface som anges i routers konfigurationsläge stoppar onödiga RIP uppdateringar så att:

  1. Bandbredden används effektivare eftersom uppdateringsmängder minskar.
  2. Istället att ta emot och bearbeta uppdateringar ignorerar nätverksenheterna onödiga uppdateringar.
  3. Mindre uppdateringstrafik desto mindre säkerhetsrisker.

Bild 3: Laborations topologi – exempel 1

Bild 4: IP adresser
Används tre classful nätverksadresser

  • 172.30.0.0/16
  • 192.168.4.0/24
  • 192.168.5.0/24
Nätverksadressen 172.30.0.0/16 är uppdelad i tre delnät adresser

  • 172.30.1.0/24
  • 172.30.2.0/24
  • 172.30.3.0/24
R1(config)#interface fa0/0
R1(config-if)#ip address 172.30.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface s0/0/0
R1(config-if)#ip address 172.30.2.1 255.255.255.0
R1(config-if)#no router rip
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#network 172.30.1.0
R1(config-router)#network 172.30.2.0
R1(config-router)#passive-interface FastEthernet 0/0
R1(config-router)#end
R1#show run
R2(config)#interface s0/0/0
R2(config-if)#ip address 172.30.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface fa0/0
R2(config-if)#ip address 172.30.3.1 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface s0/0/1
R2(config-if)#ip address 192.168.4.9  255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#no router rip
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 172.30.0.0
R2(config-router)#network 192.168.4.8
R2(config-router)#passive-interface FastEthernet 0/0
R2(config-router)#end
R2#show run
R3(config)#interface fa0/0
R3(config-if)#ip address 192.168.5.1  255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface s0/0/1
R3(config-if)#ip address 192.168.4.10  255.255.255.0
R3(config-if)#no router rip
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#network 192.168.4.0
R3(config-router)#network 192.168.5.0
R3(config-router)#passive-interface FastEthernet 0/0
R3(config-router)#end
R3#show run

Angränsade routrar och automatiskt route summering/aggregering

Bild 5: Boundary router

En router som är i mitten av ett classful nätverk och som använder diskontinuerliga IP adresser kallas angränsade eller “boundary router”. En sådan router binder ihop olika nätverk som kör olika routing-protokoll. Ibland används samma namn, boundary router, till routrar mellan autonom system – AS.

Sådana routrar aggregerar vägar automatiskt exempelvis nätverksadresser 172.30.1.0, 172.30.2.0 och 172.30.3.0 representeras med adressen 172.30.0.0

Fördelar och nackdelar med automatisk route summering/aggregering

Routrar som kör RIP uppdaterar varandra helt automatiskt i ett classful nätverk. Ett sådant nätverk använder endast en och samma nätmask för alla delnät och därmed behövs inte inkludera nätmasken. Detta minskar mängden av routing-information i uppdateringarna vilket resulterar att bandbredden används effektivare. Men när ett nätverk adresseras diskontinuerligt fungerar inte routing mellan de olika delnät.

RIP har varit ett av de första routing-protokoll som har använts aktivt mellan ISP och deras kundnätverk. Men idag behöver kundnätverk inte skicka eller ta emot uppdateringar istället räcker att skicka datatrafiken till ISP router när den lokala kund-router inte har en route till någon destination. Detta möjliggörs med statiska route.

Bild 6: Default route – exempel 2

I exempel 2 router R3 är ISP-router och som sådan tillhandahåller Internet-uppkoppling. Routrar R2 och R2 utbyter inte uppdateringar istället R2 konfigureras på R2 en permanent väg som alla datatrafik ska använda. En sådan väg heter “Defaulte route”. När det gäller R3 ska denna router använda en statisk väg mot R2.

Konfigurationer – exempel 2

Enligt bild 6 kan detta nätverk konfigureras som följande:

R2(config)#router rip
R2(config-router)#no network 192.168.4.0
R2(config-router)#exit
R2(config)#ip route 0.0.0.0   0.0.0.0  serial 0/0/1
R3(config)#no router rip
R3(config)#ip route 172.30.0.0  255.255.252.0  serial 0/0/1
R1#show ip route

Posten markerad med R visar att nätverk 172.30.3.0 har en administrativ kostnad på 120 och Metric 1. Denna route har tagits emot i en uppdatering via R2.

Bild 7: R1# show ip route
R2#show ip route

Posten markerad med R visar att nätverk 172.30.1.0 har en administrativ kostnad på 120 och Metric 1. Denna route har tagits emot i en uppdatering via R1.

Posten markerad med S* är en default route som är direkt anslutet till R2.

Bild 8: R2# show ip route
R3#show ip route

Posten markerad med S visar att nätverk 172.30.0.0 är en statisk route som anses vara direkt anslutet.

Bild 9: R3# show ip route

Propagera Default Route in RIPv1

För att tillhandahålla Internetanslutning till alla andra nätverk behöver statiska route inkluderas i uppdateringar. Du skulle kunna konfigurera på R1 en statisk default route mot R2 men en sådan konfiguration är inte lämplig i ett nätverk som troligen kommer att ändras ofta. Istället låter man att detta hanteras av en dynamisk routing-protokoll. I flera routing-protokoll kan du använda kommandot default-information originate för att statiska default route propageras till alla närliggande routrar.

R2(config)# router rip
R2(config-router)# default-information originate
R2(config-router)# end
R2# debug ip rip
R2# undebug all

Bild 10: R1# show ip route

Bild 10 illustrerar routers R1 routing-tabell. Posten markerad som R* indikerar att den statisk default route har tagits emot via uppdateringar från router R2. Nu har R1 en anslutning till LAN på router R3.