RIP inledning

Routing Information Protocol är ett distansvektor protokoll och det enklaste att börja med. Först svarar jag på frågan: Vad menas med distansvektor?

  • Distans – hur långt borta är ett destinationsnätverk? Protokollets metric avgör avståndet.
  • Vektor – vilket håll ska dirigeras ett paket så att det kommer fram till destinationsnätverk? Interfacet anslutet till nästa router som leder till destinationsnätverk.

Jag fortsätter att förklara flera begrepp till med hjälp av exempel nedan:

I detta nätverk inkluderas tre routrar som kör distansprotokollet RIP. Det hjälper till att bygga upp routrarnas routing-tabell.

Bild 1: Hur byggs upp routing-tabeller

Så fort jag konfigurerar interface med sin respektive IP adress börjar routrar att bygga upp egna routing-tabeller. Det kan illustreras med bild 1 där varje router registrerar direkt anslutna nätverk i sin routing-tabell. Direkt anslutna nätverk är de enda som finns i en routing-tabell innan det uppstår routing-uppdateringar mellan routrar. Lägg märke på sista kolumnen i routing-tabellerna som indikerar Metric-värde.

Nu kommer jag att aktivera distansvektor protokollet RIP och därefter ska jag studera vad som kommer att hända med routrarnas routing-tabeller. Jag förväntar mig att routrarna kommer att växla routing-tabellerna så att routing-information uppdaterar routing-tabellerna.

RIP konfiguration

  • R1(config)# router rip
  • R1(config-router)# network 10.1.1.0
  • R1(config-router)# network 172.16.10.0
  • R1(config-router)# end
  • R1# show ip route
  • R2(config)# router rip
  • R2(config-router)# network 172.16.10.0
  • R2(config-router)# network 172.16.11.0
  • R2(config-router)# end
  • R2# show ip route
  • R3(config)# router rip
  • R3(config-router)# network 172.16.11.0
  • R3(config-router)# network 10.2.2.0
  • R3(config-router)# end
  • R3# show ip route

  • R1 har tagit emot adresserna 172.16.11.0 och 10.2.2.0 genom sitt interface f0/1
  • Nätverket 172.16.11.0 är en router ifrån R1
  • Nätverket 10.2.2.0 är två router ifrån R1
  • R2 har tagit emot adressen 10.1.1.0 genom sitt interface fa0/1 och adressen 10.2.2.0 genom sitt interface fa0/0
  • Nätverket 10.1.1.0 är en router ifrån R2
  • Nätverket 10.2.2.0 är en router ifrån R2
  • R3 har tagit emot adresserna 172.16.10.0 och 10.1.1.0 genom sitt interface fa0/0
  • Nätverket 172.16.10.0 är en router ifrån R3
  • Nätverket 10.1.1.0 är två routrar ifrån R3