Laboration 1 och 2

I denna laborationer ska implementeras DHCP-, DNS- och MAIL -server.

Studera nätverksteknologin nedan:

Bild 1: Första nätverkstopologi med två DHCP servrar

Serverroller

  • 192.168.1.97 DHCP server för domänen diginto.se
  • 192.168.1.98 DHCP server för domänen jensen.se
  • 192.168.1.99 DNS server för diginto.se och jensen.se
  • 192.168.1.0/24 DIGINTO-nätverk
  • 192.168.2.0/24 JENSEN-nätverk

DHCP nätverkstrafik

DHCP automatiserar tilldelning av IP- adresser och andra IP nätverksparametrar.

  • När en DHCP-klient kontaktar DHCP-servern begär denna att få låna en IP adress.
  • Servern väljer en adress från en konfigurerad adressintervall (IP pool) och lånar IP adressen för en viss tid.
  • När tiden börjar ta slut kan klienterna fråga servern om en förlängning annars måste adresserna returneras till poolen för återanvändning.
Bild 2: DHCP process

Observationer på nätverkstopologi

Att ha två server känns inte rätt eftersom det kan hända följande:

  • DHCP klient skickar en DHCP Discover
  • Digintos DHCP server eller Jensens DHCP tar emot och skickar tillbaka DHCP Offer paket
  • Men klienten i DIGINTO-nätverk måste ha IP-adressen från 192.168.1.0/24 och inte från 192.168.2.0/24
  • Vad för IP-adress kommer DHCP-klienten att få låna?
  • Hur bestäms att DHCP-klient får låna en IP-adress från Diginto DHCP-servern?

För att svara frågorna behöver vi gå genom detaljer i DHCP-processen och med det behöver vi högre kunskaper som tillåter oss förstå förklaringarna.

Jag förklarar först det som händer i början (DHCP-klient)

  • DHCP processen använder kommunikationssätt: broadcast
  • DHCP-klient, som inte har en IP-adress, måste konstruera ett DHCP-discovery paket som ska skicas ut i sitt lokala nät. Brodacast paketet måste ha IP adress och MAC-adress
  • DHCP-klient behöver ett protokoll: UDP
  • UDP-protokollet använder som identifikation portnummer 67 och 68. Portnummer 68 används av klienter och portnummer för DHCP-server är 67.
  • DHCP-klient och UDP portnummer:
    • Source UDP portnummer 68
    • Destination UDP portnummer 67
  • Nu är dessa segment skickas till Nätverksskiktet yttrar sig andra problem
  • DHCP-klienten har inte någon IP-adress än därmed identifieras med 0.0.0.0
  • DHCP-klienten har en MAC-adress, till exempel 0010.11B2.B259
  • Det vill säga source IP 0.0.0.0 och source MAC 0010.11B2.B259
  • Destinationens adresser? Det är okänd för klienten därför blir så här:
  • Destination IP 0.0.0.0
  • Destination MAC FFFF.FFFF.FFFF (en MAC-broadcast adress)

Nu kan vi föreställa oss att Jensen server tar emot DHCP-DISCOVERY packet. En DHCP server svarar med DHCP OFFER med vissa villkor. Kommunikationssättet är broadcast och ett sådant meddelande tillåts endast till nätverksenheter som är anslutna till ett lokalt nätverk. Jensen DHCP server har en IP-pool med default gateway som inte är lokalt: 192.168.2.1/24 därmed Jensen server kommer att ignorera broadcast meddelande från lokala nätverksenheter.

Diginto DHCP server tar emot DHCP-DISCOVERY eftersom den tolkar styrinformation så här:

  • Servern läser av följande:
    • Destination portnummer 67
    • Destination IP 0.0.0.0
    • Destination MAC FFFF.FFFF.FFFF
    • Source IP 0.0.0.0
    • Source MAC 0010.11B2.B259
  • Server söker efter en IP-adress att låna ut i sin IP-pool
  • Bygger upp ett DHCP-OFFER paket och skickar ut till DHCP-klienten med hjälp av klientens MAC-adress.

Det finns fler förklaringar som beskriver DHCP-processen men det krävs högre kunskaper inom nätverksteknologier. Vi återkommer att ta upp DHCP i senare lektioner.

Praktisk lösning 1

  • Vi konfigurerar endast en DHCP-server med två IP-pool: en för diginto.se och en för jensen.se
  • Vi konfigurerar istället en MAIL server och en DNS server. Studera bilden nedan:
Bild 3: En DHCP-server med två IP-pool

Konfigurationer

DHCP server:

  • Diginto-klienter kommer att få låna IP-adresser utan problem, men inte Jensen-klienter.
  • Jensen-klienters broadcast går inte genom router R1
  • Enda sättet att DHCP-DISCOVER tar sig genom router är med hjälp av en DHCP-relay agent.
  • En DHCP-relay agent kommer att kommunicera med DHCP-server och leverera DHCP-klienters broadcast meddelande.
  • En DHCP-relay agent konfigureras med kommando ip helper-address

Router R1 konfiguration

  • Router>enable
  • Router#
  • Router#configure terminal
  • Router(config)#hostname R1
  • R1(config)#interface fa0/0
  • R1(config-if)#description LAN Diginto
  • R1(config-if)#ip address 192.168.1.1 255.255.255.0
  • R1(config-if)#no shut
  • R1(config-if)#exit
  • R1(config)#interface fa0/1
  • R1(config-if)#description LAN Jensen
  • R1(config-if)#ip address 192.168.2.1 255.255.255.0
  • R1(config-if)#no shut
  • R1(config-if)#end
  • R1#show ip interface brief
  • R1#
  • R1#configure terminal
  • R1(config)#int fa0/1
  • R1(config-if)#ip helper-address 192.168.1.197
  • R1(config-if)#end
  • R1#

Switch konfigurationer

  • Switch s1 konfiguration
  • Switch>enable
  • Switch#
  • Switch#configure terminal
  • Switch(config)#hostname s1
  • s1(config)#
  • s1(config)#interface vlan 1
  • s1(config-if)#ip address 192.168.1.2 255.255.255.0
  • s1(config-if)#no shut
  • s1(config-if)#end
  • s1#
  • Switch s2 konfiguration
  • Switch>enable
  • Switch#
  • Switch#configure terminal
  • Switch(config)#hostname s2
  • s2(config)#
  • s2(config)#interface vlan 1
  • s2(config-if)#ip address 192.168.2.2 255.255.255.0
  • s2(config-if)#no shut
  • s2(config-if)#end
  • s23