Ethernet konfigurering

Routers Ethernet eller FastEthernet interface används som gateway för datorer i det lokala nätverket. Till dessa datorer innebär att routers Ethernet interface är både huvudingång och huvudutgång, just därför måste varje Ethernet interface på routern ha en giltig IP adress konfigurerat. Varje gång ett interface konfigureras ska interfacet aktiveras med kommandot: no shutdown

Bild 1: Grundkonfiguration

Nätverket ovan illustrerar ett switch-baserat LAN med namn Stockholm. Till switchen sw1 ansluts en dator med IP-adress 192.168.10.10 och routern RS. Interfacet anslutet till routern RS är Fa0/0 och som adresseras med IP-adressen 192.168.10.1 som en del av Stockholm LAN. Från datorn vill man hantera sw1 och RS. Två alternativ finns:

  • via en konsolkabel direkt anslutet till konsolport
  • via VTY terminaler

Switch hantering via konsolkabel

Som default fungerar alla portar i en switch utan någon konfigurering. I princip ansluts alla nätverksenheter till en switch som är centralt för lokal kommunikation. Dock alla nätverksenheter ska ha konfigurerats med en unikt IP-adress och en tillhörande nätmask.

Vi börjar med att ansluta datorn till switchen via en konsolkabel och därefter lägga en beskrivning på porten som ska anslutas till routern RS:

Switch>enable
Switch#configure terminal
Switch(config)#interface FastEthernet 0/1
Switch(config-if)#description To RS
Switch(config-if)#exit

Switch hantering via terminaler

Normalt konfigureras inte switchar med IP-adresser, men i administrativt syfte kan switchar konfigureras med en IP adress så att den fungerar som en host i ett lokala nät. Då är det möjligt att komma åt switchen via IP-baserade protokoll som Telnet och SSH.

Alla Cisco switchar stödjer virtuella LAN. Sådana nätverk måste IP-adresseras och tilldelas ett antal portar så att tillhörande nätverksenheter ansluts till de. Som default har switchar ett virtuellt LAN, VLAN 1 interface. Det kan användas för fjärradministrering, det vill säga utan konsolkabel. Så här kan VLAN 1 konfigureras:

Switch>enable
Switch#configure terminal
Switch(config)#interface VLAN 1
Switch(config-if)#ip address 192.168.1.2  255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.1.1
Switch(config)#exit
Switch#

Det förutsätter att VTY har konfigurerats med lösenord. Om det är så kan Telnet eller SSH startas på datorn för att komma åt switchen sw1, till exempel så här c:\> telnet 192.168.1.2

Router hantering via konsolport

Det förutsätter att routern RS har inte IP-konfigurerats. Koppla datorn och routern RS via en konsolkabel och exekvera följande:

RS>enable
RS#configure terminal
RS(config)#interface FastEthernet 0/0
RS(config-if)#ip address 192.168.10.1 255.255.255.0
RS(config-if)#description To SW1 at Stockholm LAN
RS(config-if)#no shutdown

Nu kan du koppla av konsolkabeln och ansluta datorn till switchen och startar antingen exempelvis Telnet.

Seriella Interface

Routerns seriella interface används för att koppla routern till WAN och därmed till ISP utrustning. I seriella länkar där två nätverksenheter är ihopkopplade ska en enhet hålla synkroniseringstiden och fungera som DCE (Data Communication Equipment) medan den andra enheten ska fungerar som DTE (Data Terminal Equipment). Seriella interface kräver synkroniseringstid i kommunikationsprocessen. Som default är alla Cisco routrar konfigurerade till DTE enheter, precis som vanliga datorer.

Bilden nedan illustrerar att routern RS seriellt gränssnitt S0/0/0 är sammankopplad till ett WAN-nätverk adresserat som 192.168.11.0/30. Interfacet konfigureras med IP-adressen 192.168.11.1 och som DCE så att den ger synkroniseringstiden.

Bild 2: Router RS konfiguration

RS(config)#interface Serial 0/0/0
RS(config-if)#ip address  192.168.11.1  255.255.255.252
RS(config-if)#clock rate 64000
RS(config-if)#description To WAN
RS(config-if)#no shutdown
RS(config-if)#exit

Kommandot no shutdown

När kommandot no shutdown exekveras visas meddelande liknande nedan:

*Mar 1 01:16:08.212: %Link-3-UPDOWN: interface FastEthernet0/0, changed state to up

*Mar 1 01:16:09.214: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Båda meddelande är viktiga.

  • Det första meddelandet anger att uppkopplingen är fysiskt fungerande.
  • Det andra meddelande anger att datalänk skiktet är i drift.

Obs: Även om kommandot no shutdown aktiverar ett interface, så blir det inte aktivt förrän interfacet börjar ta emot signaler.

Verifieringar

Med kommandot RS# show running-config visas alla utförda konfigurationer, sök efter:

  • Routerns namn
  • Interface FastEthernet 0/0
  • IP adresser
  • Interface Serial 0/0/0
  • IP adresser
  • DCE clock rate
  • Banner meddelande

Med kommando RS# show ip route kommer att visas om routerns interface är

  • lokalt kopplade (C – connected)
  • statiska route till olika nätverksdestinationer (S – static)
  • dinamiska route till olika nätverksdestinationer (R – RIP, D – EIGRP, O – OSPF, osv.)
  • Nätverks IP adress direkt relaterad till interfacet

Med kommandot RS# show interface brief får man fram en sammanfattat mängd av information:

  • Interface namn
  • IP Adress
  • Metod (manuellt eller dynamisk)
  • Status (det fysiska interfacet up eller down)
  • Protocol (konfigurationer ip, dce)

När en routers interface status och protocol visar interfacet som “up” betyder att interface fungerar på det fysiska skiktet och på det datalänk skiktet. Annars är deras status “administratively down

Här nedan en översikt på nödvändiga kommando:

Basic Router Interface Configuration 
Global konfigurationsläge Router>enable
Router#configure terminal
Configuring an interface Router(config)# interface type number
Router(config-if)# ip address address mask
Router(config-if)#description description
Router(config-if)# no shutdown
Saving changes on a router Router# copy running-config  startup-config
Examining the output of show commands Router# show running-config
Router# show ip route
Router# show ip interface brief
Router# show interfaces