RIPv1 egenskaper

Här nedan visas adresseringstabellen och topologin som används i denna lektion för att se detaljer i skillnader mellan RIPv1 och RIPv2. Anta att alla interfaces har konfigurerats enligt tabellen nedan, därefter konfigureras routrarna med RIPv1 så här:

  • R1(config)# router rip
  • R1(config-router)# network 172.30.1.0
  • R1(config-router)# network 172.30.2.0
  • R1(config-router)# network 209.165.200.0
  • R3(config)# router rip
  • R3(config-router)# network 172.30.100.0
  • R3(config-router)# network 172.30.110.0
  • R3(config-router)# network 172.30.200.16
  • R3(config-router)# network 209.165.200.32

Router R2 har ett delnät adresserat med 10.1.0.0/16 och flera delnät som inte längre existerar. Nätverkstrafiken till dessa delnät fortsätter ankomma till router R2 och därför behövs en statisk aggregerad route till en destination där alla paket tas bort.

Bild 1: RIPv1 vs RIPv2 topologi
Enhet Interface IP adress Nätmask
R1 Fa0/0  172.30.1.1  255.255.255.0
Fa0/1  172.30.2.1  255.255.255.0
S0/0/0  209.165.200.230  255.255.255.252
R2 Fa0/0 10.1.0.1  255.255.0.0
S0/0/0 209.165.200.229  255.255.255.252
S0/0/1  209.165.200.233  255.255.255.252
  R3 Fa0/0 172.30.100.1  255.255.255.0
Lo0 172.30.110.1  255.255.255.0
Lo1 172.30.200.17  255.255.255.240
Lo2 172.30.200.33  255.255.255.240
S0/0/1  209.165.200.234  255.255.255.252

Statisk aggregerad route

Topologin visar att R2 har en statisk aggregerad route till 192.168.0.0/16-nätverket. Detta nätverk existerar inte men det används för att ta bort paket adresserad till nätverket 192.168.0.0/16. För att simulera en väg som inte existerar använder vi ett null-interface som utgångsinterface. Du behöver inte ange några kommandon för att skapa eller konfigurera null-interfacet. Det är ett interface som är alltid upp men skickar inte eller tar emot trafik. Trafiken som skickas till null-interfacet kasseras, därmed fungerar interfacet som en virtuell utgång.

R2 (config) #ip-route 192.168.0.0 255.255.0.0 Null0

Kom ihåg att route aggregering tillåter att en enda övergripande route representera många andra route. Detta reducerar storleken på routing-tabellerna. Den statiska route på R2 använder en /16 nätmask för att aggregera alla 256 nätverk som sträcker sig från 192.168.0.0/24 till 192.168.255.0/24.

Nu konfigurerar vi RIPv1 på R2

  • R2(config)# router rip
  • R2(config-router)# network 10.1.0.0

Nu har alla routrar i topologin konfigurerats med RIPv1, förutom den statisk aggregerad route. Dynamiska routing-protokoll inkluderar inte statiska route något som kräver ytterligare konfigureringar.

Route-omfördelning eller på engelska Route Redistribution

RIP inkluderar inte statiska route i uppdateringar som skickas ut till andra routrar. Det kan ändras med kommandot redistribute static. I vår exempeltopologi vill vi att RIP-processen på R2 ska inkludera den statiska och aggregerade vägen (192.168.0.0/16) i RIP processen genom att importera routen i processen och därefter skicka den till R1 och R3.

  • R2 (config) #router rip
  • R2 (config-router) #redistribute static

RIPv1 uppdateringar

Om du tänker exempelvis på alfabetet som börjar på a, b, c, d och så vidare kan man väl säga att varje bokstav har en vis position, eller att bokstäverna är kontinuerliga. Men när man ändrar ordningen är bokstäverna istället diskontinuerliga, även om fortfarande är de i alfabetet. Det samma händer med IP adresser där nätmasken avgör om adresserna är kontinuerliga eller diskontinuerliga. RIPv1 stödjer inte diskontinuerliga nätverk, VLSM eller Classless Inter-Domain Routing (CIDR) nätverk.

Bild 2: Diskontinuerliga nätverk

Bilden ovan visar att R1 och R2 skickar uppdateringar med samma innehåll, vägen till 172.30.0.0/16 classful nätverket med ett avstånd 1 hopp. Observera att R2 har nu två alternativ till 172.30.0.0/16-nätverket. Även om router R2 tar emot uppdateringar i vilka inkluderas den aggregerade route 172.30.0.0/16 skickar inte router R2 denna route tillbaka till R1 och R2. Det här kan bekräftas med kommandot debug ip rip på router R2.

Nu är det frågan varför inte skickas tillbaka samma route till routrarna R1 och R3? Svaret är att regeln Split Horisont är i kraft och den tillåter inte att skicka tillbaka en route som ursprungligen har tagits emot från samma interface.

Hur bestäms nätmask?

Det är sagt att nätmasken inkluderas inte i RIPv1 uppdateringar och att nätmasken bestäms av klasserna. Med illustrationen nedan vill jag visa hur RIPv1 använder nätmasken för det utgående interfacet. Router R4 läggs till topologin och den ansluts till switchen. R4 är ansluten till R3 via FastEthernet 0/0 interface på 172.30.100.0/24-nätverket. Figuren visar att router R3 väljer nätmasken /24 och routern skickar till R4 route adresserad som 172.30.110.0/24. Däremot inkluderas inte /28 delnäten.

Bild 3: Hur nätmask definieras i RIPv1

Routern R3 behöver bestämma vilka 172.30.0.0-delnät som ska inkluderas i routing-uppdateringarna. I enlighet med hur ett classful routing fungerar R3 väljer att använda som nätmask det utgående interfacets nätmask.

Loopback interface – Lo

Ett loopback-interface är programbaserat som används för att emulera ett fysiskt interface. Liksom andra interface kan loopback interface tilldelas en IP-adress. Ett loopback-interface kan pingas och delnätet kan inkluderas i routing-uppdateringar. I en laborationsmiljö är loopback-interface användbara för att skapa ytterligare nätverk utan att behöva lägga till fler fysiska interface på routern. Loopback interface är idealiska för att simulera flera nätverk kopplade till samma router. I vårt exempel behöver R3 inte 4 fysiska LAN-interface för att visa flera VLSM delnät. Istället använder router R3 loopback-interface.

  • Adressen 172.30.0.0/16 delas upp till /24 delnät och resulterar: 172.30.0.0/24, 172.30.1.0/24, 172.30.2.0/24, 172.30.3.0/24 och så vidare fram till 172.30.255.0. Därav tilldelas adresserna:
    • R1: Fa0/0 172.30.1.1 och Fa0/1  172.30.2.1
    • R2 Fa0/0 172.30.100.1, Lo0 172.30.110.1; Lo1 172.30.200.17; Lo2 172.30.200.33
  • Adressen 172.30.200.0/24 delas upp ytterligare till /28 delnät (255.255.255.240) och resulterar i 172.30.200.0/28, 172.30.200.16/28, 172.30.200.32/28 och så vidare. Från dessa adresser tilldelas några till R3 interface Lo1 och Lo2.